如果你是哈利·波特迷,你会知道魔法世界有它自己的货币系统 —— 就如海格告诉哈利的:“十七个银西可(Sickle)兑一个加隆(Galleon),二十九个纳特(Knut)兑一个西可,很容易。”现在,给定哈利应付的价钱 P 和他实付的钱 A,你的任务是写一个程序来计算他应该被找的零钱。
输入格式:
输入在 1 行中分别给出 P 和 A,格式为 Galleon.Sickle.Knut
,其间用 1 个空格分隔。这里 Galleon
是 [0, 107] 区间内的整数,Sickle
是 [0, 17) 区间内的整数,Knut
是 [0, 29) 区间内的整数。
输出格式:
在一行中用与输入同样的格式输出哈利应该被找的零钱。如果他没带够钱,那么输出的应该是负数。
输入样例 1:
10.16.27 14.1.28
输出样例 1:
3.2.1
输入样例 2:
14.1.28 10.16.27
输出样例 2:
-3.2.1
代码实现:
import java.io.*;
/**
* @author yx
* @date 2022-07-19 18:14
*/
public class Main {
static PrintWriter out=new PrintWriter(System.out);
static BufferedReader ins=new BufferedReader(new InputStreamReader(System.in));
static StreamTokenizer in=new StreamTokenizer(ins);
public static void main(String[] args) throws IOException {
//进行二次切割
String[] split=ins.readLine().split("\\s");
String[] P_s1=split[0].split("\\.");
String[] P_s2=split[1].split("\\.");
// System.out.println(P_s1[0]+" "+P_s1[1]+" "+P_s1[2]+" ");
// System.out.println(P_s2[0]+" "+P_s2[1]+" "+P_s2[2]+" ");
long s1_kn=(long) 17*29*Integer.parseInt(P_s1[0])+(long) 29*Integer.parseInt(P_s1[1])+(long) Integer.parseInt(P_s1[2]);
long s2_kn=(long) 17*29*Integer.parseInt(P_s2[0])+(long) 29*Integer.parseInt(P_s2[1])+(long) Integer.parseInt(P_s2[2]);
long an=s2_kn-s1_kn;
if(an<0) {
an=-1*an;
String ans = an / (17 * 29) + "." + (an / 29) % 17 + "." + an % 29;
System.out.println("-"+ans);
}else {
String ans = an / (17 * 29) + "." + (an / 29) % 17 + "." + an % 29;
System.out.println(ans);
}
}
}