火星人是以 13 进制计数的:
- 地球人的 0 被火星人称为 tret。
- 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
- 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29
翻译成火星文就是 hel mar
;而火星文 elo nov
对应地球数字 115
。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13
代码实现:
import java.io.*;
import java.util.HashMap;
import java.util.Locale;
/**
* @author yx
* @date 2022-07-20 15:42
*/
public class Main {
static PrintWriter out=new PrintWriter(System.out);
static BufferedReader ins=new BufferedReader(new InputStreamReader(System.in));
static StreamTokenizer in=new StreamTokenizer(ins);
public static void main(String[] args) throws IOException {
in.nextToken();
int N=(int) in.nval;
String[] s1={"tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
String[] s2={"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
HashMap<String,Integer>map=new HashMap<>();
HashMap<String,Integer>map1=new HashMap<>();
for (int i = 1; i<=12; i++) {
map.put(s1[i-1],i);
}
for (int i = 0; i<13; i++) {
map1.put(s2[i],i);
}
for (int i = 0; i < N; i++) {
String s=ins.readLine();
char[] ch=s.toCharArray();
if(ch[0]>='0'&&ch[0]<='9'){
int ans=Integer.parseInt(s);
if(ans/13!=0){
if(ans%13==0) System.out.println(s1[ans/13-1]);
else System.out.println(s1[ans/13-1]+" "+s2[ans%13]);
}else {
System.out.println(s2[ans%13]);
}
}else {
if(ch.length>5){
String[] split=s.split(" ");
System.out.println(map.get(split[0])*13+map1.get(split[1]));
}else {
if (map.containsKey(s))System.out.println(map.get(s)*13);
else System.out.println(map1.get(s));
}
}
}
}
}