Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.
Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (≤200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.
Sample Input:
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9
Sample Output:
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0
Process
我刚开始直接用map<string, string>写的,每次输出的时候给后面的课程排个序,结果最后一个测试点超时了,用输入输出优化后也依旧超时,然后为了不排序,那么我每次插入新课程的时候注意一下不就好了,把小根堆放进map容器里,就是这样:
map<string, priority_queue<int, vector, greater>>ma;
这样就不用每次排序咯,直接输出就好了~~~我看有的答案中用了hash,怎么说呢我从来没用过hash算法,因为C++里的容器已经够用了,我待会儿去看看他们怎么写的…
Code
我是用堆优化写的,很简单
#include<bits/stdc++.h>
using namespace std;
int n, m;
map<string, priority_queue<int, vector<int>, greater<int>>>ma;
int main()
{
ios::sync_with_stdio(0);
cin >> n >> m;
for (int i = 0; i < m; i++)
{
int num, g;
cin >> g >> num;
for (int i = 0; i < num; i++)
{
string str;
cin >> str;
ma[str].push(g);
}
}
for (int i = 0; i < n; i++)
{
string str;
cin >> str;
cout << str << " " << ma[str].size();
if (ma[str].size() == 0)
cout << endl;
else
{
cout << " ";
while (!ma[str].empty())
{
cout << ma[str].top() << (ma[str].size() == 1 ? "\n" : " ");
ma[str].pop();
}
}
}
return 0;
}