A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.
Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.
Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4
Process
模拟n叉树的广度优先搜索即可。
Code
#include<bits/stdc++.h>
using namespace std;
#define maxn 100010
int num[maxn];
struct node {
int high = 0;
vector<int> child;
}link[maxn];
int n, m;
void bfs() {
queue<int >q;
q.push(1);
link[1].high = 1;
while (!q.empty()) {
int top = q.front();
q.pop();
for (int i = 0; i < link[top].child.size(); i++)
{
int temp = link[top].child[i];
q.push(temp);
link[temp].high = link[top].high + 1;
}
}
}
int main()
{
cin >> n >> m;
for (int i = 0; i < m; i++)
{
int temp, tempn;
cin >> temp >> tempn;
for (int j = 0; j < tempn; j++) {//孩子节点
int t;
cin >> t;
link[temp].child.push_back(t);
}
}
bfs();//广度优先
int maxx = -1, maxm = -1;
for (int i = 1; i <= n; i++)
num[link[i].high]++;
for (int i = 1; i <= n; i++)
if (maxx < num[i])
{
maxx = num[i];
maxm = i;
}
cout << maxx << " " << maxm;
return 0;
}