本题要求读入 N 名学生的成绩,将获得某一给定分数的学生人数输出。
输入格式:
输入在第 1 行给出不超过 105 的正整数 N,即学生总人数。随后一行给出 N 名学生的百分制整数成绩,中间以空格分隔。最后一行给出要查询的分数个数 K(不超过 N 的正整数),随后是 K 个分数,中间以空格分隔。
输出格式:
在一行中按查询顺序给出得分等于指定分数的学生人数,中间以空格分隔,但行末不得有多余空格。
输入样例:
10
60 75 90 55 75 99 82 90 75 50
3 75 90 88
输出样例:
3 2 0
代码实现:
import java.io.*;
public class Main {
public static void main(String[] args) throws IOException{
// TODO Auto-generated method stub
BufferedReader input = new BufferedReader(new InputStreamReader(System.in));
int N = Integer.parseInt(input.readLine());
String[] str = input.readLine().split(" ");
int[] arr = new int[N];
for(int i=0;i<N;i++) arr[i] = Integer.parseInt(str[i]);
String[] str1 = input.readLine().split(" ");
int M = Integer.parseInt(str1[0]);
int[] score = new int[M];
int[] output = new int[M];
for(int i=0;i<M;i++) score[i] = Integer.parseInt(str1[i+1]);
for(int i=0;i<M;i++) for(int j=0;j<N;j++) if(score[i]==arr[j]) output[i]++;
for(int i=0;i<M-1;i++) System.out.print(output[i] + " ");
System.out.println(output[M-1]);
}
}
Tips:
有一个点超时,优化也没用,Java的局限性