本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .
,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
注意: 题目保证不存在只有小数点的输入。
输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
- 如果密码合法,输出
Your password is wan mei.
; - 如果密码太短,不论合法与否,都输出
Your password is tai duan le.
; - 如果密码长度合法,但存在不合法字符,则输出
Your password is tai luan le.
; - 如果密码长度合法,但只有字母没有数字,则输出
Your password needs shu zi.
; - 如果密码长度合法,但只有数字没有字母,则输出
Your password needs zi mu.
。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.
代码实现:
import java.io.*;
import java.util.Locale;
/**
* @author yx
* @date 2022-07-26 13:09
*/
public class Main {
static PrintWriter out=new PrintWriter(System.out);
static BufferedReader ins=new BufferedReader(new InputStreamReader(System.in));
static StreamTokenizer in=new StreamTokenizer(ins);
public static void main(String[] args) throws IOException {
in.nextToken();
int N = (int) in.nval;
for (int j = 0; j < N; j++) {
char[] arr = ins.readLine().toUpperCase(Locale.ROOT).toCharArray();
int length = arr.length;
int zm_no = 0;
int sz_no = 0;
int dian_no = 0;
int bhf_no = 0;
for (int i = 0; i < length; i++) {
if ((arr[i] >= 'A' && arr[i] <= 'Z')) {
zm_no++;
} else if ((arr[i] >= '0' && arr[i] <= '9')) {
sz_no++;
} else if (arr[i] == '.') {
dian_no++;
} else {
bhf_no++;
}
}
int length_no = dian_no + sz_no + zm_no;
if (length_no >= 6) {//长度合法
if (bhf_no > 0) {
System.out.println("Your password is tai luan le.");
} else if (sz_no == 0) {
System.out.println("Your password needs shu zi.");
} else if (zm_no == 0) {
System.out.println("Your password needs zi mu.");
}else {
System.out.println("Your password is wan mei.");
}
} else {
System.out.println("Your password is tai duan le.");
}
}
}
}