- 递归函数求值
时间限制:1Sec内存限制:128MB通过:316提交:522
递归
题目描述
按如下递归公式求函数值:x=1时,f(x)=10;x>1时,f(x)=f(x-1)+2。
输入
整型变量x(0 < x < 10000)。
输出
f(x)的值。
样例输入
10
样例输出
28
来源
2017 大一限时训练(一)
#include<bits/stdc++.h>
using namespace std;
int po(int x)
{
if(x==1)
{
return 10;
}
else
return po(x-1)+2;
}
int main()
{
int x;
cin>>x;
po(x);
cout<<po(x);
}