请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
样例:">输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7
代码实现:
import java.io.*;
import java.util.HashMap;
/**
* @author yx
* @date 2022-07-20 12:59
*/
public class Main {
static PrintWriter out=new PrintWriter(System.out);
static BufferedReader ins=new BufferedReader(new InputStreamReader(System.in));
static StreamTokenizer in=new StreamTokenizer(ins);
public static void main(String[] args) throws IOException {
char[] split=ins.readLine().toLowerCase().toCharArray();
HashMap<Character ,Integer> map=new HashMap<>();
int length=split.length;
for (int i = 0; i < length; i++) {
if((split[i]>='a'&&split[i]<='z'))
{
map.put(split[i],map.getOrDefault(split[i],0)+1);
}
}
int max_no=0;
char max_=' ';
for (char i : map.keySet()) {
if(map.get(i)>max_no){
max_no=map.get(i);
max_=i;
}
}
System.out.println(max_+" "+max_no);
}
}